Firefox System Requirements | Call +1-855-785-2511

System Requirements and Recommendations for Firefox

Below are the Firefox system requirements required to install Firefox and run successfully by operating system listed given:
Recommendations are also given so that your Firefox can work properly


Linux

firefox system requirements

Software Requirements

Note:
Linux distributors provide packages for your distribution which have different requirements.

Firefox will not run on Linux without the following packages.

  • GTK+ 2.18 or higher
  • GLib 2.22 or higher
  • Pango 1.14 or higher
  • X.Org 1.0 or higher (1.7 or higher is recommended)
  • libstdc++ 4.3 or higher

The following packages are recommended for optimal functionality.

  • NetworkManager 0.7 or higher
  • DBus 1.0 or higher
  • HAL 0.5.8 or higher
  • GNOME 2.16 or higher

Mac

firefox system requirements

Operating Systems

  • Mac OS X 10.6
  • Mac OS X 10.7
  • Mac OS X 10.8

Recommended Hardware

  • Macintosh computer with an Intel x86 processor
  • 512 MB of RAM
  • 200 MB hard drive space

Windows

firefox system requirements

Operating Systems

  • Windows XP SP2
  • Windows Server 2003
  • Windows Vista
  • Windows 7
  • Windows 8

Please note that while 32-bit and 64-bit versions of Windows Vista and Windows 7 can be used to run Firefox, only 32-bit Firefox creation is supported at this time

Hardware

  • Pentium 4 or newer processor that supports SSE2
  • 512MB of RAM
  • 200MB of hard drive space

 

 

One thought on “Firefox System Requirements | Call +1-855-785-2511

  1. Pingback: renew my MSN premium subscription

Leave a Reply

Your email address will not be published. Required fields are marked *